5 followers Follow

Drag Drop Photos From Picasa or Windows Explorer into BookSmart

I am using Windows 8.1.

I am using BookSmart 3.4.4

I just upgraded to 8.1, and 3.4.4. Historically I could "drag and drop" straight from Windows Explorer, or straight from Picasa, into a Page Layout in BookSmart. This is no longer functioning - when I drag the photo into the Page Layout in BookSmart I just see a circle with a diagonal line through it indicating it wont accept the "drag and drop".

All of my books are 440 pages so importing them manually via the "Add a folder" from "my computer" is an unsustainable model.

Any ideas? Ive been Googling and searching the forums - looks like other people have this issue and fixed it by adjusting "run as administrator" functions - but I can't figure out exactly what they are talking about... are they changing settings in BookSmart? In Windows?

Thanks for any help!


Please sign in to leave a comment.



I figured it out.. on accident...

I added a folder, ie "add photos" via "my computer" then selected a folder via the BookSmart interface - then dragged and dropped the photos. As soon as I did this, it immediately allowed me to begin dragging/dropping via windows explorer and picasa. Weird, but it worked.

molleen 0 votes


Can you please expand on what you did to get it working ... I also cannot do drag an drop in Booksmart3.4.4 on Windows 7.

H & S Sikkema 0 votes

Same problem. Windows 8.1, Booksmart For me a reason not to create a book, as the main way I used to operate the tool is no longer supported. Molleens work around is not working for me. Running booksmart as administrator.

alexanderhof 0 votes

Can any one please help with this. I've imported all the pics into blurb but it still wont let me just drag and drop like it used to and its driving me insane... HELP! please

michmc84 0 votes

I've made about fifty books with booksmart on windows, and have made them all by drag and drop.
Has this been removed from Booksmart 3.4.7 ?
Do I need to use alternate software?

Kevin Break 0 votes

Community is not available in this language

Help Center