Using the InDesign Plug-in with older Mac OS X versions

The Macintosh version of the Blurb InDesign Plug-in can only be installed on Macs running Mac OS X 10.6 or newer. If you're running an older version of Mac OS X we recommend updating your computer to a newer version.

If an upgrade of the operating system is not possible you may contact our customer support department and request a manual installer for your particular configuration. In your request, please provide the current Mac OS X version and the version of Adobe InDesign.

Have more questions? Submit a request
Log In